Overlay Bug

View previous topic View next topic Go down

Overlay Bug

Post by Animus on 2015-06-04, 00:28

I saved inside comet cave the other day, and when I loaded up my file, I selected it, it loaded, but then reverted back to the file select screen, and I had to select it again to continue playing, but this left an odd overlay bug, as if 2 of the files were running in the same client at the same time.

Needless to say this puts an extra burden on frame/lag problems for the engine, but it seems to go away visually at the very least after leaving a screen. During this odd period Theo in comet cave was following an invisible "me" and walked through walls and left me, but still participated in fights as per normal.

The only real problem here is that now, when selecting my files since then, the same process happens. It's as if I have to have 2 games running inside it, but only 1 visually effected. I see and hear no other sounds effects after a few seconds of playing, but notice more lag, on top of the already seemingly strained engine.(currently in the first town after comet cave, super laggy with this bug around.

Hope this can be fixed in a patch some time in the future, not sure how to re-create it, but I did do some pvp with my brother after we beat the second gym, the lobby syncing that you may have tweaked could end up being the culprit behind this all, but I only noticed after booting up later in comet cave.

Hope you are able to work this out, could be a hassle to find. Sad
avatar
Animus
Baashaun
Baashaun

Posts : 31
Join date : 2015-06-04
Age : 24

View user profile

Back to top Go down

Re: Overlay Bug

Post by h0b099j on 2015-06-04, 00:30

Well it's triggered when you load your save right? Check your save files to make sure they are not messed up (both named the same would be my unlikely guess.)
avatar
h0b099j
Tofurang
Tofurang

Posts : 138
Join date : 2015-05-29
Age : 18
Location : Bemidji, MN

View user profile

Back to top Go down

Re: Overlay Bug

Post by Animus on 2015-06-04, 13:11

I only have 1 save file, and there is only one in my save folder. Ask anything you want, and I will answer what I can.

Yes it is triggered when I load a save, but there is still only one game being played when I play, just the visuals of 2, and some extra lag in the background. My game is on top of the 2 visuals, so it isn't effecting the actual gameplay, and isn't starting any battles from the second visuals.
avatar
Animus
Baashaun
Baashaun

Posts : 31
Join date : 2015-06-04
Age : 24

View user profile

Back to top Go down

Re: Overlay Bug

Post by h0b099j on 2015-06-04, 13:17

Woah, that's really cool. My hunch that is probably wrong anyhow is something to do with the way directx and your video drivers are interacting with the RMXP engine.

The reason why that's wrong is that it's not only effecting visuals, but gameplay aspects. I wish I could help you more, maybe JV (should he happen to show up) knows something.
avatar
h0b099j
Tofurang
Tofurang

Posts : 138
Join date : 2015-05-29
Age : 18
Location : Bemidji, MN

View user profile

Back to top Go down

Re: Overlay Bug

Post by Animus on 2015-06-04, 13:22

Update, surpsingly: This all happened when me and my brother got the Shiny s51' from MYSTERY GIFT!(we did all of this stuff like one after the other haha) It seems to be a bad load script or something, after checking for mystery gifts. Decided to load this time without checking it like I usually do, and it didn't make me select a file twice!

On the other hand, if I check mystery gift, and then go to select the file, it makes me select my file twice to play and causes the problem at hand.

So it is possible to work around it, but at least we found the cause. And is repeatable. Good luck finding the cause, haha. Not sure if it is possible for any of the previous actions I have talked about to effect the Mystery Gift function, but this should at least bring the bug closer to being fixed.

Again, ask anything you want, I can give the info you want Smile
avatar
Animus
Baashaun
Baashaun

Posts : 31
Join date : 2015-06-04
Age : 24

View user profile

Back to top Go down

Re: Overlay Bug

Post by h0b099j on 2015-06-04, 13:25

Wow, that's even cooler. Are you checking mystery gift every time you play? because there is little reason to, so far they have all been given upon updates to the game, so if the patcher runs and has to install something than you can check it, otherwise it is highly unlikely that anything will be there.
avatar
h0b099j
Tofurang
Tofurang

Posts : 138
Join date : 2015-05-29
Age : 18
Location : Bemidji, MN

View user profile

Back to top Go down

Re: Overlay Bug

Post by Animus on 2015-06-04, 13:29

I do normally check every time I start up, as I only recently joined Uranium a couple days ago, and got that shiny from it lol. Thanks for clarifying when it is normally used. Razz

That's why I decided to restart the client and try NOT using the Mystery Gift, to take out another variable, and behold the problem didn't happen haha.
avatar
Animus
Baashaun
Baashaun

Posts : 31
Join date : 2015-06-04
Age : 24

View user profile

Back to top Go down

Re: Overlay Bug

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum